ログイン
ユーザ名:

パスワード:


パスワード紛失

新規登録
メインメニュー
フォーラム一覧   -   トピック一覧
   Flash Builder 4
     プロジェクトのアップロードについて
投稿するにはまず登録を

スレッド表示 | 古いものから 前のトピック | 次のトピック | 下へ
投稿者 トピック
nod
投稿日時: 2012-4-9 20:13
管理人
登録日: 2006-1-10
居住地:
投稿: 184
Re: プロジェクトのアップロードについて
lingtaro さん

サーバアップ時の変更点ありがとうございます。
φ(..)メモメモ

二か所の変更でプログラム自体に
大きな変更点なくできるんですね。

環境を作り直した時に
レンタルサーバまたはPHPCloudやAzureのようなクラウドに
アップするケースを考えて試してみたいと思います。

共有していただきありがとうございました。
lingtaro
投稿日時: 2012-4-9 3:23
一見さん
登録日: 2012-3-28
居住地: 山口県
投稿: 3
Re: プロジェクトのアップロードについて
nodさん

はい、設定ファイルの記述とserviceフォルダの中身に問題がありました。

結局、amf_config.iniの変更部分は以下の2か所だけ。
webroot =
amf.directories[]=

できるだけシンプルな、Mysqlとの連携だけにしぼったプロジェクトを作りなおし試したところうまくいきました。
nod
投稿日時: 2012-4-3 21:10
管理人
登録日: 2006-1-10
居住地:
投稿: 184
Re: プロジェクトのアップロードについて
lingtaro さん

わたしも一時期Flex + Zend + SQLServerを試していました。

今は環境がなくて確認できない状態となっていますが
どのように解決されましたでしょうか。
やはり設定ファイルの記述でしょうか?

後学のために教えていただけますと助かります。
lingtaro
投稿日時: 2012-4-3 8:09
一見さん
登録日: 2012-3-28
居住地: 山口県
投稿: 3
Re: プロジェクトのアップロードについて
自己解決いたしました
lingtaro
投稿日時: 2012-3-28 9:43
一見さん
登録日: 2012-3-28
居住地: 山口県
投稿: 3
プロジェクトのアップロードについて
FlashBuilder4.6を使用してPHPでMysqlとのデータ連携アプリの作成に挑戦している初心者です。行き詰ってしまいどなたかご教授いただければ幸いです。

とても初歩的なことなのですが、ローカルで動作していたものがレンタルサーバー(さくら)にアップしたところ、エラーが出てしまいます。
以下、私が行った試行錯誤です。

まず、

amf_config.ini 書き直し
[zend]
;set the absolute location path of webroot directory, example:
;Windows: C:\apache\www
;MAC/UNIX: /username/apache/www
webroot =/home/username/www

;set the absolute location path of zend installation directory, example:
;Windows: C:\apache\PHPFrameworks\ZendFramework\library
;MAC/UNIX: /user/apache/PHPFrameworks/ZendFramework/library
zend_path =/home/username/ZendFramework-1.11.11/library

[zendamf]
amf.production = false
amf.directories[]=projectname/services

次に、

MyOriginalService.as に以下を追記

_serviceControl.endpoint = "http://username.sakura.ne.jp/projectname/gateway.php";

ZendFrameworkもルート直下に置いています。

実行時のエラーは、以下の通り

Send failed
Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Status 500: url: 'http://username.sakura.ne.jp/projectname/gateway.php'

試しに、

ZendAMFのResponse、HTTP.phpの59行目に・・・というヒントを見つけ試しましたがダメでした。

どこか根本的に大きなところを間違っているのでしょうか?一番大事なところが動作しないので本当に困っています。
どなたかお助けください。
スレッド表示 | 古いものから 前のトピック | 次のトピック | トップ

投稿するにはまず登録を